Ticket #15 (closed task: fixed)
Use a more meaningful name for buildAlias
|Reported by:||tobi||Owned by:||tobi|
Description (last modified by tobi) (diff)
The buildAlias method in Utilities actually is about to be renamed to getAlias (see #13). However, the "Alias" part is still missing the point, IMHO. (Same for buildAliasFromFile if it should persist.)
What the method actually does, is checking if the desired name is not already defined in the target collection. It is questionable whether the term "Alias" is understood that way by everyone.
The method name should reflect this behaviour in a better way, semantically.